6planドキュメント

.NetFrameworkのインストール off

admin to  

プログラムを実行するには、.NET Framework2.0以上が必要となります。お使いのパソコンにインストールされているか確認してください。Vistaをお使いの方はすでに3.0以上がインストールされているのでこの作業は必要ありません。

APC-ProVer1.98bよりバージョン3.5が必要となります。 (Windows7の方はインストール済みです。)

インストールされている場合は、「スタート」→「コントロールパネル」→「プログラムの一覧と削除」の画面に.NET Framework2.0以上が表示されます。バージョンが3.5以外の場合はバージョンアップが必要です。

画面1:「.NET Framework2.0(3.5)をインストールせずに、プログラムを実行した場合」
dotnet

画面2:「バージョンが古い場合」

dotnet2

画面3:「.NET Framework2.0がインストールされている場合」

dotnet3

以下のマイクロソフトのホームページより再頒布可能パッケージをダウンロードしてインストールしてください。(変更されている可能性があります。)

.NET Framework 3.5 ダウンロード

また、以下の日本語 Language Packもインストールされることをお勧めします。こちらは、なくてもプログラムを実行させることができますが、エラーメッセージが英語のまま出力されることがあります。

Microsoft .NET Framework 3.5 日本語 Language Pack

3.5は2.0の上に3.0と3.5が上乗せされたような仕組みになっています。そのためにインストール時に2.0や3.0が存在しているとエラーになることがあるようです。 その場合はいったんインストール済みの.NET FrameWorkをアンインストールしてください。

※マイクロソフトが提供するライブラリについてのトラブルは当方で責任は負えません。ご了承ください。

さらに詳しく知りたい場合は、ヤフーやグーグルで「.NET Framework 3.5 インストール」といったキーワードでお調べください。